Main Page | Report Page

 

  .NET DotNet Forum Index » General Discussion » Error: "The windows Installer Service is...

Author Message
Richard Carver...
Posted: Sun Nov 08, 2009 4:40 am
 
When I try to install .NET 3.5+SP1 a popup appears telling me:

"The windows Installer Service is unavailable. Another applictaion may be running setup..."

No! There is nothing else running.
How can I fix the problem?

Richard
 
VanguardLH...
Posted: Sun Nov 08, 2009 5:53 am
 
Richard Carver wrote:

Why are you yanking the discussion away from the other newsgroups to
which you posted? If your discussion was not appropriate for those
other newsgroups to continue its discussion by visitors there then you
should not have posted there. It is rude to post in a newsgroup and
then hide the remainder of the discussion elsewhere. There are rare few
occasions where the use of the FollowUp-To header is appropriate.

The original Newsgroups list was restored in my reply.

Quote:
When I try to install .NET 3.5+SP1 a popup appears telling me:

"The windows Installer Service is unavailable. Another applictaion may be running setup..."

No! There is nothing else running.
How can I fix the problem?

Do you have the Automatic Updates service enabled? If so, did you
configure the Windows Update function in Windows to automatically
download and install updates? (see note below) If so, you may have
received updates from Microsoft that are pending the shutdown of Windows
(and then its restart during which the remaining portion of the
installation can replace the inuse files that it couldn't touch before).
So reboot your computer to see if the problem goes away. That should
eliminate any pending installations.

Note: It has been noted that some updates are getting pushed onto user's
hosts although they have Windows Update configured to notify only. They
don't want to have the updates downloaded automatically when they become
available. They don't want the state of their host changed whenever
Microsoft decides to push an update by having them get installed without
first prompting the user to ask for permission. But updates have
appeared despite configuring WU to only notify of update or even with WU
disabled (which disables the function but does not stop the AU service).
Users have reported receiving updates with just the AU service enabled
and running which performed an unsolicited reboot of their host.
 
Family Tree Mike...
Posted: Sun Nov 08, 2009 7:20 am
 
VanguardLH wrote:
Quote:
Richard Carver wrote:

Why are you yanking the discussion away from the other newsgroups to
which you posted? If your discussion was not appropriate for those
other newsgroups to continue its discussion by visitors there then you
should not have posted there. It is rude to post in a newsgroup and
then hide the remainder of the discussion elsewhere. There are rare few
occasions where the use of the FollowUp-To header is appropriate.

The original Newsgroups list was restored in my reply.

When I try to install .NET 3.5+SP1 a popup appears telling me:

"The windows Installer Service is unavailable. Another applictaion may be running setup..."

No! There is nothing else running.
How can I fix the problem?


I don't know which groups were eliminated by the author, but one was
dotnet.general. Since the OP is installing .Net 3.5 + sp 1, it would be
appropriate to answer the question here, where I am seeing it. At least
it is appropriate to see an answer here by a searcher at a later date.

As the response said, rebooting should help. Just because you don't see
an active user interface to an install, does not mean one is not
occurring. You should look at the task manager, and kill any
msiexec.exe processes, then try again.

--
Mike
 
 
Page 1 of 1    
All times are GMT - 5 Hours
The time now is Fri Aug 26, 2016 12:26 pm