Main Page | Report Page

 

  Computers Forum Index » Computer - Databases - Progress » Progress V8.3C11 and V9.1 on same SCO Unix server ?...

Author Message
Frederic STOCK...
Posted: Tue Jun 16, 2009 7:23 pm
 
Hello,

is it possible to run on the same server (SCO Unix OSR5.06a) Progress
V8.3C11 and Progress V9.1 ?
I need Progress V9 for one application but have to keep Progress V8 for
another one.

Thank's.
Regards.

F. STOCK
 
Stefan M....
Posted: Wed Jun 17, 2009 2:31 pm
 
On Tue, 16 Jun 2009 17:23:08 +0200, Frederic STOCK
<f.stock at (no spam) jmontblanc.fr> wrote:


Quote:
is it possible to run on the same server (SCO Unix OSR5.06a) Progress
V8.3C11 and Progress V9.1 ?
I need Progress V9 for one application but have to keep Progress V8 for
another one.


No problem if you choose different directories for the installation.

Stefan
 
Frederic STOCK...
Posted: Wed Jun 17, 2009 5:40 pm
 
Stefan M. a écrit :
Quote:
On Tue, 16 Jun 2009 17:23:08 +0200, Frederic STOCK
f.stock at (no spam) jmontblanc.fr> wrote:


is it possible to run on the same server (SCO Unix OSR5.06a) Progress
V8.3C11 and Progress V9.1 ?
I need Progress V9 for one application but have to keep Progress V8 for
another one.


No problem if you choose different directories for the installation.

Stefan


Hi Stephan,

I installed Progress V9.1E on /u/dlc91 dir, do not copy the scripts on
/usr/bin.
The installation ended without error.
For the Progress V8.3C11 application, it's still working well as before,
no changes; but when trying toi launch Progress V9.1E utility, I get
some environnement variables error:

../pro ==> slib_env could not be found.
progress shared library not set correctly
progress DLC environment variable may not be set correctly

actually DLC=/u/dlc83 (which correspond to Progress V8.3C dir.

So, how could I create a Progress V9.1E environment different from
Progress V8.3C ?

Thank's.
Regards.

F. STOCK
 
Frederic STOCK...
Posted: Wed Jun 17, 2009 6:29 pm
 
Frederic STOCK a écrit :
Quote:
Stefan M. a écrit :
On Tue, 16 Jun 2009 17:23:08 +0200, Frederic STOCK
f.stock at (no spam) jmontblanc.fr> wrote:


is it possible to run on the same server (SCO Unix OSR5.06a) Progress
V8.3C11 and Progress V9.1 ?
I need Progress V9 for one application but have to keep Progress V8
for another one.


No problem if you choose different directories for the installation.

Stefan


Hi Stephan,

I installed Progress V9.1E on /u/dlc91 dir, do not copy the scripts on
/usr/bin.
The installation ended without error.
For the Progress V8.3C11 application, it's still working well as before,
no changes; but when trying toi launch Progress V9.1E utility, I get
some environnement variables error:

./pro ==> slib_env could not be found.
progress shared library not set correctly
progress DLC environment variable may not be set correctly

actually DLC=/u/dlc83 (which correspond to Progress V8.3C dir.

So, how could I create a Progress V9.1E environment different from
Progress V8.3C ?

Thank's.
Regards.

F. STOCK


If I create a shell script which launch the Progress V9.1 broker
including DLC=/u/dlc91 environment, it will work, no ?

I change DLC variable from /u/dlc83 to /u/dlc91 from my shell, and now I
can work with Progress V9.1 tools; I created a base test (copy from
sports database), mount a broker, monitor my test database with promon, ...

I think I'm going thru this way.

F. STOCK
 
Stefan M....
Posted: Thu Jun 18, 2009 11:32 am
 
On Wed, 17 Jun 2009 15:40:30 +0200, Frederic STOCK
<f.stock at (no spam) jmontblanc.fr> wrote:

Quote:
Stefan M. a écrit :
On Tue, 16 Jun 2009 17:23:08 +0200, Frederic STOCK
f.stock at (no spam) jmontblanc.fr> wrote:


is it possible to run on the same server (SCO Unix OSR5.06a) Progress
V8.3C11 and Progress V9.1 ?
I need Progress V9 for one application but have to keep Progress V8 for
another one.


No problem if you choose different directories for the installation.

Stefan


Hi Stephan,

I installed Progress V9.1E on /u/dlc91 dir, do not copy the scripts on
/usr/bin.
The installation ended without error.
For the Progress V8.3C11 application, it's still working well as before,
no changes; but when trying toi launch Progress V9.1E utility, I get
some environnement variables error:

./pro ==> slib_env could not be found.
progress shared library not set correctly
progress DLC environment variable may not be set correctly

actually DLC=/u/dlc83 (which correspond to Progress V8.3C dir.

So, how could I create a Progress V9.1E environment different from
Progress V8.3C ?

Thank's.
Regards.

F. STOCK

Hi,

this should work:

cd /u/dlc91/bin
.. proenv
- now you are in 9.1 environment -

Stefan
 
Frederic STOCK...
Posted: Thu Jun 18, 2009 1:50 pm
 
Stefan M. a écrit :
Quote:
On Wed, 17 Jun 2009 15:40:30 +0200, Frederic STOCK
f.stock at (no spam) jmontblanc.fr> wrote:

Stefan M. a écrit :
On Tue, 16 Jun 2009 17:23:08 +0200, Frederic STOCK
f.stock at (no spam) jmontblanc.fr> wrote:


is it possible to run on the same server (SCO Unix OSR5.06a) Progress
V8.3C11 and Progress V9.1 ?
I need Progress V9 for one application but have to keep Progress V8 for
another one.

No problem if you choose different directories for the installation.

Stefan

Hi Stephan,

I installed Progress V9.1E on /u/dlc91 dir, do not copy the scripts on
/usr/bin.
The installation ended without error.
For the Progress V8.3C11 application, it's still working well as before,
no changes; but when trying toi launch Progress V9.1E utility, I get
some environnement variables error:

./pro ==> slib_env could not be found.
progress shared library not set correctly
progress DLC environment variable may not be set correctly

actually DLC=/u/dlc83 (which correspond to Progress V8.3C dir.

So, how could I create a Progress V9.1E environment different from
Progress V8.3C ?

Thank's.
Regards.

F. STOCK

Hi,

this should work:

cd /u/dlc91/bin
. proenv
- now you are in 9.1 environment -

Stefan


Hi Stephan,

that's what I did, and it worked.
I've now another problem to resolv: connect this SCO Unix OSR5.06a
Progress V9.1E via a Windows ODBC driver.

Thank's.
Regards.

F. STOCK
 
Stefan M....
Posted: Mon Jun 22, 2009 4:01 pm
 
On Thu, 18 Jun 2009 11:50:25 +0200, Frederic STOCK
<f.stock at (no spam) jmontblanc.fr> wrote:


Quote:
Hi Stephan,

that's what I did, and it worked.
I've now another problem to resolv: connect this SCO Unix OSR5.06a
Progress V9.1E via a Windows ODBC driver.

Thank's.
Regards.


Hi,

i am not sure but i think ODBC and SQL92 is not supported. (caused of
missing multithreading)
But you can try to use the old sql89 drivers (_prooi...), perhaps you
need to run a full installation and extract the files from a .pl

Stefan
 
Frederic STOCK...
Posted: Mon Jun 22, 2009 7:57 pm
 
Stefan M. a écrit :
Quote:
On Thu, 18 Jun 2009 11:50:25 +0200, Frederic STOCK
f.stock at (no spam) jmontblanc.fr> wrote:


Hi Stephan,

that's what I did, and it worked.
I've now another problem to resolv: connect this SCO Unix OSR5.06a
Progress V9.1E via a Windows ODBC driver.

Thank's.
Regards.


Hi,

i am not sure but i think ODBC and SQL92 is not supported. (caused of
missing multithreading)
But you can try to use the old sql89 drivers (_prooi...), perhaps you
need to run a full installation and extract the files from a .pl

Stefan


Hi Stephan,

you're right, SQL92 is not supproted under SCO Unix OSR5.05, 5.06, 5.07
but only under Unixware.

Thank's.

Fred.
 
 
Page 1 of 1    
All times are GMT
The time now is Sun Apr 20, 2014 4:13 pm